• Re: Tiger lake -march swi

    From paulie420@1:103/705 to Digital Man on Sun Oct 31 05:42:00 2021
    I'm trying to build syncterm on a frame.work laptop AND ZorinOS Pro.

    https://sourceforge.net/p/syncterm/tickets/
    digital man

    Yea, I noticed after posting that there isn't a switch I can set on my end. Weird, tho - cause other distros on this hardware built Syncterm just fine... maybe ZorinOS reports something different than other OSes - at any rate, I've created a ticket - thanks for pointing me there.



    |07p|15AULIE|1142|07o
    |08.........
    --- SBBSecho 3.14-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From paulie420@1:103/705 to Spellchecker on Wed Jan 26 16:54:00 2022
    [Frame.work laptop doesn't compile Syncterm]
    You have to upgrade g++/gcc compiler to a newer version (10+)
    see https://stackoverflow.com/questions/64493692/cc1plus-error-bad-value-tiger or-march-switch-compilation-error/66562219
    for details

    Thanks for the reply; I have since switched to an Arch based install and compile Sync many ways - but appreciate you reading my info posted and giving me a reply.

    I sometimes come across a system/setup that won't compile Syncterm for one reason or another and will remember to check for >10.0 of g++/gcc in the future. Thanks.



    |07p|15AULIE|1142|07o
    |08.........
    --- SBBSecho 3.14-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Gamgee@1:123/115 to paulie420 on Wed Jan 26 19:42:00 2022
    paulie420 wrote to Spellchecker <=-

    [Frame.work laptop doesn't compile Syncterm]
    You have to upgrade g++/gcc compiler to a newer version (10+)
    see https://stackoverflow.com/questions/64493692/cc1plus-error-bad-value-tiger or-march-switch-compilation-error/66562219
    for details

    Thanks for the reply; I have since switched to an Arch based
    install and compile Sync many ways - but appreciate you reading
    my info posted and giving me a reply.

    I sometimes come across a system/setup that won't compile
    Syncterm for one reason or another and will remember to check for
    10.0 of g++/gcc in the future. Thanks.

    I don't think Syncterm requires v10+ of gcc. I've compiled it many times, including recent/latest versions, on Slackware 14.2, with gcc version 5.5.0.



    ... Internal Error: The system has been taken over by sheep at line 19960
    === MultiMail/Linux v0.52
    --- SBBSecho 3.14-Linux
    * Origin: Palantir * palantirbbs.ddns.net * Pensacola, FL * (1:123/115)
  • From Spellchecker@1:103/705 to Gamgee on Thu Jan 27 01:34:24 2022
    Re: Re: Tiger lake -march swi
    By: Gamgee to paulie420 on Wed Jan 26 2022 07:42 pm

    paulie420 wrote to Spellchecker <=-

    [Frame.work laptop doesn't compile Syncterm]
    You have to upgrade g++/gcc compiler to a newer version (10+)
    see https://stackoverflow.com/questions/64493692/cc1plus-error-bad-value-tiger or-march-switch-compilation-error/66562219
    for details

    Thanks for the reply; I have since switched to an Arch based
    install and compile Sync many ways - but appreciate you reading
    my info posted and giving me a reply.

    I sometimes come across a system/setup that won't compile
    Syncterm for one reason or another and will remember to check for
    10.0 of g++/gcc in the future. Thanks.

    I don't think Syncterm requires v10+ of gcc. I've compiled it many times, including recent/latest versions, on Slackware 14.2, with gcc version 5.5.0.

    It depends on a hardware you are compiling at.
    Here specifically the combination of a tigerlake CPU with gcc v9 leads to a failure with -march= option values supported.

    -Spellchecker
    --- SBBSecho 3.14-Linux
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)
  • From Gamgee@1:103/705 to Spellchecker on Thu Jan 27 10:11:00 2022
    Spellchecker wrote to Gamgee <=-

    I sometimes come across a system/setup that won't compile
    Syncterm for one reason or another and will remember to check for
    10.0 of g++/gcc in the future. Thanks.

    I don't think Syncterm requires v10+ of gcc. I've compiled it many times,
    in
    cluding recent/latest versions, on Slackware 14.2, with gcc
    version 5.5.0.

    It depends on a hardware you are compiling at.
    Here specifically the combination of a tigerlake CPU with gcc v9
    leads to a failure with -march= option values supported.

    Ahhhh, OK. That makes sense to me, should have caught the reference to tigerlake earlier. Thanks for the info.



    ... Something will have to be done, something irresponsible.
    --- MultiMail/Linux v0.52
    Synchronet Palantir BBS * palantirbbs.ddns.net * Pensacola, FL
    * Origin: Vertrauen - [vert/cvs/bbs].synchro.net (1:103/705)