• nftables-0.8

    From Maurice Kinal@1:153/7001 to Benny Pedersen on Mon Dec 4 13:54:18 2017
    Hey Benny!

    ----- "<Esc>:read !ldd /sbin/nft | sed 's/\t/ /g'" starts
    linux-vdso.so.1 (0x00007fff48d84000)
    libmnl.so.0 => /usr/lib/libmnl.so.0 (0x00007fa551d59000)
    libnftnl.so.7 => /usr/lib/libnftnl.so.7 (0x00007fa551b35000)
    libreadline.so.7 => /lib/libreadline.so.7 (0x00007fa5518f2000)
    libgmp.so.10 => /usr/lib/libgmp.so.10 (0x00007fa551691000)
    libc.so.6 => /lib/libc.so.6 (0x00007fa551318000)
    libncursesw.so.6 => /lib/libncursesw.so.6 (0x00007fa5510c5000)
    /lib/ld-linux-x86-64.so.2 (0x00007fa551f5e000)
    ----- "<Esc>:read !ldd /sbin/nft | sed 's/\t/ /g'" ends

    I had to add libmnl-1.0.4 and libnftnl-1.0.8 to the basic system in order to satisfy the above dependencies. The rest I already have.

    ----- "<Esc>:read !file /usr/lib/{libmnl.so.0.2.0,libnftnl.so.7.0.0}" starts /usr/lib/libmnl.so.0.2.0: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
    /usr/lib/libnftnl.so.7.0.0: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
    ----- "<Esc>:read !file /usr/lib/{libmnl.so.0.2.0,libnftnl.so.7.0.0}" ends

    I haven't tested the ipv4-filter you posted as of this writing. What are you expecting that to do?

    Life is good,
    Maurice

    ... Don't cry for me I have vi.
    --- GNU bash, version 4.4.12(1)-release (x86_64-silvermont-linux-gnu)
    * Origin: Little Mikey's Brain - Ladysmith BC, Canada (1:153/7001)
  • From Benny Pedersen@2:230/0 to Maurice Kinal on Thu Dec 14 17:34:04 2017
    Hello Maurice!

    04 Dec 2017 13:54, Maurice Kinal wrote to Benny Pedersen:

    I had to add libmnl-1.0.4 and libnftnl-1.0.8 to the basic system in
    order to satisfy the above dependencies. The rest I already have.

    same on gentoo, while libnftnl is still unstable on this version above

    I haven't tested the ipv4-filter you posted as of this writing. What
    are you expecting that to do?

    what is a firewall supposed to do ? :=)


    Regards Benny

    ... there can only be one way of life, and it works :)

    --- Msged/LNX 6.2.0 (Linux/4.14.4-gentoo (i686))
    * Origin: I will always keep a PC running CPM 3.0 (2:230/0)