• RE: GAMMA 451.5L Available - fixes Web Double Login Problem

    From HECTOR SANTOS@1:124/5013 to All on Thu Jan 31 19:17:14 2019
    Date: Thu, 29 Sep 2005 01:26:34 -0400
    From: HECTOR SANTOS
    To: MICHAEL PURDY
    Subject: RE: GAMMA 451.5L Available - fixes Web Double Login Problem Newsgroups: winserver.public.gamma.testing
    Message-ID: <1127971594.40.1127959231@winserver.com>
    References: <1127959231.40.1126844949@winserver.com>
    X-WcMsg-Attr: Rcvd
    X-Mailer: Wildcat! Interactive Net Server v7.0.454.5
    Lines: 53

    I am a COMPLETE lost of reproducing this double login. While the space issue was a reason and it was one way to create it, this was fixed and I can't see any other way to create it.

    I have to do something to get this fixed because it is the last thing that is holding us up.

    Any repeatability logic anyone may have will be greatly appreciated.


    -- Hector

    On 9/28/05 10:00 PM, MICHAEL PURDY wrote to HECTOR SANTOS:

    Hector

    Since the 15 September update I have only seen the stuck user issue once at
    my
    end.

    I noticed today that GEOFF BROZNY is logged on to multiple nodes at winserver.com.

    Are you still in the process of refining the multi node login issue fix or is

    this now a new issue?

    Mike

    On 9/16/05 12:22 AM, HECTOR SANTOS wrote to All:

    The GAMMA AUP was updated with 1 new file: WCSERVER.EXE

    This fixes the problem where a web user has spaces in his login name and
    was
    causing the web server to relogin the user in multiple nodes. This only happen with the new web authentication methods DIGEST or COOKIES added
    since
    451.5. The original BASIC authentication method never had this problem.
    So
    if you were using BASIC AUTHENTICATION only, you never experienced this.
    But
    if you enabled DIGEST and/or COOKIE login methods, you may have seen this problem when a user used spaces in his or her name. In this case, you
    need
    the new wcserver.exe.

    Thanks for your patience. Who would of thought that a user will have a
    typo
    space in his name?! <g>

    To use the GAMMA AUP, type:

    AUTOUPDATE -GAMMA

    -- Hector





    --- Platinum Xpress/Win/WINServer v3.1
    * Origin: Prison Board BBS Mesquite Tx //telnet.RDFIG.NET www. (1:124/5013)
  • From HECTOR SANTOS@1:124/5013 to All on Thu Jan 31 19:17:14 2019
    Date: Thu, 29 Sep 2005 07:21:40 -0400
    From: HECTOR SANTOS
    To: MICHAEL PURDY
    Subject: RE: GAMMA 451.5L Available - fixes Web Double Login Problem Newsgroups: winserver.public.gamma.testing
    Message-ID: <1127992900.40.1127959231@winserver.com>
    References: <1127959231.40.1126844949@winserver.com>
    X-WcMsg-Attr: Rcvd
    X-Mailer: Wildcat! Interactive Net Server v7.0.454.5
    Lines: 24

    Question. Are you using cookies?

    I am suspecting that most people have not switched to using cookies and are not reporting it as much. I think this is all related to cookies. I just turned it off at winserver.com to see if continues to happen here.

    -- Hector

    On 9/28/05 10:00 PM, MICHAEL PURDY wrote to HECTOR SANTOS:

    Hector

    Since the 15 September update I have only seen the stuck user
    issue once at my end.

    I noticed today that GEOFF BROZNY is logged on to multiple nodes at winserver.com.

    Are you still in the process of refining the multi node login issue
    fix or is this now a new issue?

    Mike


    --- Platinum Xpress/Win/WINServer v3.1
    * Origin: Prison Board BBS Mesquite Tx //telnet.RDFIG.NET www. (1:124/5013)
  • From MICHAEL PURDY@1:124/5013 to All on Thu Jan 31 19:17:14 2019
    Date: Thu, 29 Sep 2005 07:47:39 -0400
    From: MICHAEL PURDY
    To: HECTOR SANTOS
    Subject: RE: GAMMA 451.5L Available - fixes Web Double Login Problem Newsgroups: winserver.public.gamma.testing
    Message-ID: <1127994459.40.1127992900@winserver.com>
    References: <1127992900.40.1127959231@winserver.com>
    X-WcMsg-Attr: Rcvd
    X-Mailer: Wildcat! Interactive Net Server v7.0.454.5
    Lines: 44

    Hector

    I do not use cookies. Since turning cookies off sometime back I have NOT seen any reoccurance of multiple nodes being taken up.

    What I have seen is an INDIVIDUAL user being stuck, requiring wcOnline to be stopped and started to clear the user.

    Your thinking may well be on the right track given that we first started discussing this issue around the time you introduced the digest and cookie option.

    Mike

    On 9/29/05 7:21 AM, HECTOR SANTOS wrote to MICHAEL PURDY:

    Question. Are you using cookies?

    I am suspecting that most people have not switched to using cookies and are
    not
    reporting it as much. I think this is all related to cookies. I just
    turned
    it off at winserver.com to see if continues to happen here.

    -- Hector

    On 9/28/05 10:00 PM, MICHAEL PURDY wrote to HECTOR SANTOS:

    Hector

    Since the 15 September update I have only seen the stuck user
    issue once at my end.

    I noticed today that GEOFF BROZNY is logged on to multiple nodes at winserver.com.

    Are you still in the process of refining the multi node login issue
    fix or is this now a new issue?

    Mike




    --- Platinum Xpress/Win/WINServer v3.1
    * Origin: Prison Board BBS Mesquite Tx //telnet.RDFIG.NET www. (1:124/5013)
  • From HECTOR SANTOS@1:124/5013 to All on Thu Jan 31 19:17:14 2019
    Date: Thu, 29 Sep 2005 08:49:14 -0400
    From: HECTOR SANTOS
    To: MICHAEL PURDY
    Subject: RE: GAMMA 451.5L Available - fixes Web Double Login Problem Newsgroups: winserver.public.gamma.testing
    Message-ID: <1127998154.40.1127994459@winserver.com>
    References: <1127994459.40.1127992900@winserver.com>
    X-WcMsg-Attr: Rcvd
    X-Mailer: Wildcat! Interactive Net Server v7.0.454.5
    Lines: 55

    I tried everything I can think of. Recording users URLS and repeat the sequence of commands, etc, nothing.

    Anyway, I'll keep looking over the weekend.

    --- Hector

    On 9/29/05 7:47 AM, MICHAEL PURDY wrote to HECTOR SANTOS:

    Hector

    I do not use cookies. Since turning cookies off sometime back I have NOT
    seen
    any reoccurance of multiple nodes being taken up.

    What I have seen is an INDIVIDUAL user being stuck, requiring wcOnline to be stopped and started to clear the user.

    Your thinking may well be on the right track given that we first started discussing this issue around the time you introduced the digest and cookie option.

    Mike

    On 9/29/05 7:21 AM, HECTOR SANTOS wrote to MICHAEL PURDY:

    Question. Are you using cookies?

    I am suspecting that most people have not switched to using cookies and
    are
    not
    reporting it as much. I think this is all related to cookies. I just
    turned
    it off at winserver.com to see if continues to happen here.

    -- Hector

    On 9/28/05 10:00 PM, MICHAEL PURDY wrote to HECTOR SANTOS:

    Hector


  • From MICHAEL PURDY@1:124/5013 to All on Thu Jan 31 19:17:14 2019
    Date: Thu, 29 Sep 2005 09:24:59 -0400
    From: MICHAEL PURDY
    To: HECTOR SANTOS
    Subject: RE: GAMMA 451.5L Available - fixes Web Double Login Problem Newsgroups: winserver.public.gamma.testing
    Message-ID: <1128000299.40.1127998154@winserver.com>
    References: <1127998154.40.1127994459@winserver.com>
    X-WcMsg-Attr: Rcvd
    X-Mailer: Wildcat! Interactive Net Server v7.0.454.5
    Lines: 70

    Hector

    I am about to head off to the land of nod, but from tomorrow onwards I will start to do some testing again at my end with and without cookies enabled.

    Mike

    On 9/29/05 8:49 AM, HECTOR SANTOS wrote to MICHAEL PURDY:

    I tried everything I can think of. Recording users URLS and repeat the sequence of commands, etc, nothing.

    Anyway, I'll keep looking over the weekend.

    --- Hector

    On 9/29/05 7:47 AM, MICHAEL PURDY wrote to HECTOR SANTOS:

    Hector

    I do not use cookies. Since turning cookies off sometime back I have NOT
    seen
    any reoccurance of multiple nodes being taken up.

    What I have seen is an INDIVIDUAL user being stuck, requiring wcOnline to
    be
    stopped and started to clear the user.

    Your thinking may well be on the right track given that we first started discussing this issue around the time you introduced the digest and
    cookie
    option.

    Mike

    On 9/29/05 7:21 AM, HECTOR SANTOS wrote to MICHAEL PURDY:

    Question. Are you using cookies?

    I am suspecting that most people have not switched to using cookies
    and are
    not
    reporting it as much. I think this is all related to cookies. I just
    turned
    it off at winserver.com to see if continues to happen here.

    -- Hector

    On 9/28/05 10:00 PM, MICHAEL PURDY wrote to HECTOR SANTOS:

    Hector

    Since the 15 September update I have only seen the stuck user
    issue once at my end.

    I noticed today that GEOFF BROZNY is logged on to multiple nodes at winserver.com.

    Are you still in the process of refining the multi node login issue fix or is this now a new issue?

    Mike








    --- Platinum Xpress/Win/WINServer v3.1
    * Origin: Prison Board BBS Mesquite Tx //telnet.RDFIG.NET www. (1:124/5013)
  • From HECTOR SANTOS@1:124/5013 to All on Thu Jan 31 19:17:14 2019
    Date: Thu, 29 Sep 2005 19:19:57 -0400
    From: HECTOR SANTOS
    To: MICHAEL PURDY
    Subject: RE: GAMMA 451.5L Available - fixes Web Double Login Problem Newsgroups: winserver.public.gamma.testing
    Message-ID: <1128035997.40.1128000299@winserver.com>
    References: <1128000299.40.1127998154@winserver.com>
    X-WcMsg-Attr: Rcvd
    X-Mailer: Wildcat! Interactive Net Server v7.0.454.5
    Lines: 119

    I have a strong suspicion that it is related to cookies, but I always had that suspicion. That is why I had WINSERVER.COM use it to see if I can capture situations.

    The best I can tell is that it only happens with IE browsers (based on the HTTP logs). I have not notice a session with a FF browser exhibiting this problem.

    But I can't duplicate it.

    Take the user GEOFF case. I did this with everyone that was logged in more than once. Looking at the HTTP log, he logs in at 18:18:27 and it seems that in displaying the login default page, it creates nodes 4 to 10 for each request.

    So he clicks LOGIN after filling in name/password and the /LOGIN request
    comes in, and now wildcat logs him in at node 4:

    4 64.192.187.6 - GEOFF BROZNY -
    [28/Sep/2005:18:18:27 -0400] "GET /login?js=1

    But now it needs to display the home page and it seems for each request to complete the default.htm, a new node is used. It doesn't use node 4.

    5 64.192.187.6 - GEOFF BROZNY -
    [28/Sep/2005:18:18:27 -0400] "GET /default.htm

    7 64.192.187.6 - GEOFF BROZNY -
    [28/Sep/2005:18:18:28 -0400] "GET /index.html

    8 64.192.187.6 - GEOFF BROZNY -
    [28/Sep/2005:18:18:28 -0400] "GET /public/topframe.wct

    9 64.192.187.6 - GEOFF BROZNY -
    [28/Sep/2005:18:18:28 -0400] "GET /mainmenu.htm

    10 64.192.187.6 - GEOFF BROZNY -
    [28/Sep/2005:18:18:28 -0400] "GET /supportindex.wct

    Anyway, I am sure it is so simple I can't see it. But why only sometimes, why only a certain people (so it seems), why can't I duplicate it?

    I have no hair left <g>

    -- Hector


    On 9/29/05 9:24 AM, MICHAEL PURDY wrote to HECTOR SANTOS:

    Hector

    I am about to head off to the land of nod, but from tomorrow onwards I will start to do some testing again at my end with and without cookies enabled.

    Mike

    On 9/29/05 8:49 AM, HECTOR SANTOS wrote to MICHAEL PURDY:

    I tried everything I can think of. Recording users URLS and repeat the sequence of commands, etc, nothing.

    Anyway, I'll keep looking over the weekend.

    --- Hector

    On 9/29/05 7:47 AM, MICHAEL PURDY wrote to HECTOR SANTOS:

    Hector

    I do not use cookies. Since turning cookies off sometime back I have
    NOT
    seen
    any reoccurance of multiple nodes being taken up.

    What I have seen is an INDIVIDUAL user being stuck, requiring wcOnline
    to
    be
    stopped and started to clear the user.

    Your thinking may well be on the right track given that we first started

    discussing this issue around the time you introduced the digest and
    cookie
    option.

    Mike

    On 9/29/05 7:21 AM, HECTOR SANTOS wrote to MICHAEL PURDY:

    Question. Are you using cookies?

    I am suspecting that most people have not switched to using cookies
    and are
    not
    reporting it as much. I think this is all related to cookies. I
    just
    turned
    it off at winserver.com to see if continues to happen here.

    -- Hector

    On 9/28/05 10:00 PM, MICHAEL PURDY wrote to HECTOR SANTOS:

    Hector

    Since the 15 September update I have only seen the stuck user issue once at my end.

    I noticed today that GEOFF BROZNY is logged on to multiple nodes at

    winserver.com.

    Are you still in the process of refining the multi node login issue fix or is this now a new issue?

    Mike










    --- Platinum Xpress/Win/WINServer v3.1
    * Origin: Prison Board BBS Mesquite Tx //telnet.RDFIG.NET www. (1:124/5013)
  • From MICHAEL PURDY@1:124/5013 to All on Thu Jan 31 19:17:14 2019
    Date: Thu, 29 Sep 2005 20:18:40 -0400
    From: MICHAEL PURDY
    To: HECTOR SANTOS
    Subject: RE: GAMMA 451.5L Available - fixes Web Double Login Problem Newsgroups: winserver.public.gamma.testing
    Message-ID: <1128039520.40.1128035997@winserver.com>
    References: <1128035997.40.1128000299@winserver.com>
    X-WcMsg-Attr: Rcvd
    X-Mailer: Wildcat! Interactive Net Server v7.0.454.5
    Lines: 148

    Hector

    I know you have done your best to resolve the issue, at the moment it just appears to be one of those very evil little gremlins that does not wish to be caught.

    I agree that it appears to be cookie related, so I intend to focus my testing in that area rather than in basic auth mode.

    Mike

    On 9/29/05 7:19 PM, HECTOR SANTOS wrote to MICHAEL PURDY:

    I have a strong suspicion that it is related to cookies, but I always had
    that
    suspicion. That is why I had WINSERVER.COM use it to see if I can capture situations.

    The best I can tell is that it only happens with IE browsers (based on the
    HTTP
    logs). I have not notice a session with a FF browser exhibiting this
    problem.

    But I can't duplicate it.

    Take the user GEOFF case. I did this with everyone that was logged in more than once. Looking at the HTTP log, he logs in at 18:18:27 and it seems
    that
    in displaying the login default page, it creates nodes 4 to 10 for each
    request.

    So he clicks LOGIN after filling in name/password and the /LOGIN request comes in, and now wildcat logs him in at node 4:

    4 64.192.187.6 - GEOFF BROZNY -
    [28/Sep/2005:18:18:27 -0400] "GET /login?js=1

    But now it needs to display the home page and it seems for each request to complete the default.htm, a new node is used. It doesn't use node 4.

    5 64.192.187.6 - GEOFF BROZNY -
    [28/Sep/2005:18:18:27 -0400] "GET /default.htm

    7 64.192.187.6 - GEOFF BROZNY -
    [28/Sep/2005:18:18:28 -0400] "GET /index.html

    8 64.192.187.6 - GEOFF BROZNY -
    [28/Sep/2005:18:18:28 -0400] "GET /public/topframe.wct

    9 64.192.187.6 - GEOFF BROZNY -
    [28/Sep/2005:18:18:28 -0400] "GET /mainmenu.htm

    10 64.192.187.6 - GEOFF BROZNY -
    [28/Sep/2005:18:18:28 -0400] "GET /supportindex.wct

    Anyway, I am sure it is so simple I can't see it. But why only sometimes,
    why
    only a certain people (so it seems), why can't I duplicate it?

    I have no hair left <g>

    -- Hector


    On 9/29/05 9:24 AM, MICHAEL PURDY wrote to HECTOR SANTOS:

    Hector

    I am about to head off to the land of nod, but from tomorrow onwards I
    will
    start to do some testing again at my end with and without cookies enabled.

    Mike

    On 9/29/05 8:49 AM, HECTOR SANTOS wrote to MICHAEL PURDY:

    I tried everything I can think of. Recording users URLS and repeat the sequence of commands, etc, nothing.

    Anyway, I'll keep looking over the weekend.

    --- Hector

    On 9/29/05 7:47 AM, MICHAEL PURDY wrote to HECTOR SANTOS:

    Hector

    I do not use cookies. Since turning cookies off sometime back I
    have NOT
    seen
    any reoccurance of multiple nodes being taken up.

    What I have seen is an INDIVIDUAL user being stuck, requiring
    wcOnline to
    be
    stopped and started to clear the user.

    Your thinking may well be on the right track given that we first
    started
    discussing this issue around the time you introduced the digest and
    cookie
    option.

    Mike

    On 9/29/05 7:21 AM, HECTOR SANTOS wrote to MICHAEL PURDY:

    Question. Are you using cookies?

    I am suspecting that most people have not switched to using
    cookies
    and are
    not
    reporting it as much. I think this is all related to cookies. I
    just
    turned
    it off at winserver.com to see if continues to happen here.

    -- Hector

    On 9/28/05 10:00 PM, MICHAEL PURDY wrote to HECTOR SANTOS:

    Hector

    Since the 15 September update I have only seen the stuck user issue once at my end.

    I noticed today that GEOFF BROZNY is logged on to multiple
    nodes at
    winserver.com.

    Are you still in the process of refining the multi node login
    issue
    fix or is this now a new issue?

    Mike












    --- Platinum Xpress/Win/WINServer v3.1
    * Origin: Prison Board BBS Mesquite Tx //telnet.RDFIG.NET www. (1:124/5013)